CDH修改PySpark默认的Python版本

系统 151 0

前言

PySpark一直使用的是Linux默认的Python2.7.5版本,感觉超级不爽,于是想升个级,可怎么升啊?于是又开始了万年的Google

操作步骤

  • 安装Python3.X参考
  • 配置全局变量
            
              sudo vim /etc/profile
export PATH=/usr/bin/python3:$PATH
source /etc/profile

            
          
  • 打开CDH Web配置spark-env.sh文件如下:
    CDH修改PySpark默认的Python版本_第1张图片
    即添加:
            
              export PYSPARK_PYTHON=/usr/bin/python3
export PYSPARK_DRIVER_PYTHON=/usr/bin/python3

            
          
  • 重启CDH过时服务
    然后就就可以开心的玩耍咯
    CDH修改PySpark默认的Python版本_第2张图片
    参考

更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请请扫描上面二维码支持博主1元、2元、5元等您想捐的金额吧,狠狠点击下面给点支持吧

发表我的评论
最新评论 总共0条评论